Icon

This is the documentation of the latest development version of automaIT. The documentation of the latest stable release can be found at AUTOMAIT.

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Excerpt

Operating System

Panel
bgColorWhite
Unix-like Systems

The agent should run on every Unix operating system fulfilling the software prerequisites.

For example:

  • Linux
  • Solaris
  • CentOS

Apart from a few exceptions the agent must be started as superuser (root).

The agent will switch the user with su if the server requests a command to be executed under a different user. When using sudo please keep in mind that /etc/sudoers may override environment variables or set a specific PATH.

Panel
bgColorWhite

 Windows

The agent should run on every Windows Server environment.

The agent must be started with administration rights if the agent should perform privileged actions (e.g. program installations or access restricted directories in Windows).
This can either be achieved by configuring the agent as a Windows service or by adding it as a new task to the Windows task scheduler (with activating the flag for running with highest privileges).

Java

The following Java Runtime Environment (JRE) implementations (64bit or 32bit) starting at version 7 are supported.

Version

Status

Oracle Java 64-bit, Version 7.x or 8.x

(tick) supported (recommended)

OpenJDK Java 64-bit, Version 7.x or 8.x

(tick) supported

IBM Java 64-bit, Version 7.x or 8.x

(tick) supported
Info

If the agent start aborts with "Unsupported major.minor version 51.0" then a Java 6 is mistakenly found in PATH. Please check your PATH variable so that the bin directory of Java 7 resp. Java 8 is found first.

Installation

...